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Overview 
This Reference Guide (hereinafter referred to as "this guide") describes the specifications, 

board pattern diagram, usage, and characteristics of ultrasonic distance sensors using a low-
noise op-amp TC75S67TU. Operation control and result display can be performed on the PC 
using the microcontroller, and the software is also prepared. Please refer to this guide when 
designing this sensor using TC75S67TU. 
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1. Introduction 
The ultrasonic transducer for the ultrasonic distance sensors (hereinafter referred to as "this 

sensor") described in this guide uses C4016A1 manufactured by Nippon Ceramic Co., Ltd with 
integrated transmitter and receiver. It is designed to measure distances from 40 cm to up to 6 m 
and can be widely used for various mid-range measurement applications such as detecting objects 
with drones and measuring water levels in rivers, etc. 

The signal output from this sensor board is processed by the microcontroller to calculate the 
distance and the result is displayed. In this guide, Arduino is used for the microcontroller to enable 
voltage supplied from Arduino, so in addition to this sensor, it can be used as an ultrasonic distance 
sensor if Arduino and a personal computer are available. 

 
To download of the various offer information on this sensor reference design → 
 
The components other than the op-amp are also mounted on a compact board size of 20 mm x 

40 mm using surface mount, making it easy to use for a variety of applications. 
Note that the circuit and board pattern prepared by the reference design of this sensor described 

in this guide have jumpers and lands for un-mounted elements in consideration of expandability 
such as enhancement of noise suppression. In the schematic and bill of materials, the jumper is 
described as 0 Ω, and the non-mounted elements are described as "Not mounted". In addition, the 
wiring on the circuit diagram is indicated by dotted lines. 
 
  

Click Here 
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2. Ultrasonic Distance Sensor 
2.1. Specifications 

Table 2.1 Specifications 

Item Specifications 
I/F Arduino connections 

Control method Control from Arduino and Shield Connected PCs 
Power supply voltage 5 V from Arduino and Shield board 
Measurement distance 40 cm～6 m 

Onboard ultrasonic sensor 
Nippon Ceramic C4016A1, 

Integrated transmitter and receiver 
Measured ultrasonic frequency 40 kHz 
Onboard operational amplifier Toshiba Device & Storage TC75S67TU 
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2.2. Appearance 
 
 
 
 
 
 
 
 
 
 
 

Fig.2.1 Appearance (Top side) 

 
 
 
 
 
 
 
 
 
 

Fig.2.2 Appearance (Bottom Side) 
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3. Ultrasonic Distance Sensor Schematics and Board Pattern 
3.1. Schematics 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig.3.1 Schematics 
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3.2. Bill of Materials 

Table 3.1 Bill of Materials (Part 1) 

Item Part 
Qu
anti
ty 

Value Part name Manufactu
rer Description Package 

Name 

Standard 
Dimensions 
mm (inch) 

1 U1 1 - TCR2EE33 TOSHIBA LDO regulator SOT-553 1.6×1.6×0.55 

2 U2 1 - ADM3202ARUZ 
Analog 
Devices 

Interface IC TSSOP-16 4.5×6.6×1.1 

3 
U3, U4, 

U6 
3 - TC75S67TU TOSHIBA 

Operational 
amplifier 

SOT-353F 2.0×2.1×0.7 

4 U5 1 - C4016A1 
Nippon 
Ceramic 

Ultrasonic sensors  Φ16.2×12 

5 D1, D2 2 - BAV99 TOSHIBA 
Switching 

Diode 
SOT23 2.9×2.4×0.9 

6 D3, D4 2  - JDH2S02FS TOSHIBA 
Schottky barrier 

Diode 
FsC 1.0×0.6×0.48 

7 

C1, C2, 
C3, C4, 
C5, C7, 

C8, 
C17, 

C19,C2
4 

10 100 nF   
Ceramic 

16 V, ±10 % 
 

1.0×0.5 
(0402) 

8 C6 1 1 μF   
Ceramic 

6.3 V, ±10 % 
 

1.0×0.5 
(0402) 

9 C9 1 10 pF   
Ceramic 

50 V, ±5 % 
 

1.0×0.5 
(0402) 

10 
C10, 
C15 

2 1 nF   
Ceramic 

50 V, ±5 % 
 

1.0×0.5 
(0402) 

11 C11 1 15 pF   
Ceramic 

50 V, ±5 % 
 

1.0×0.5 
(0402) 

12 
C12, 
C14 

2 330 pF   
Ceramic 

50 V, ±5 % 
 

1.0×0.5 
(0402) 

13 C13 1 47 μF   
Ceramic 

6.3 V, ±20 % 
 

2.0×1.2 
(0805) 

14 

C16, 
C18, 
C20, 
C23 

4 10 nF   
Ceramic 

25 V, ±10 % 
 

1.0×0.5 
(0402) 

15 C21 1 10 μF   
Ceramic 

25 V, ±10 % 
 

2.0×1.2 
(0805) 

16 C22 1 2.2 nF   
Ceramic 

50 V, ±10 % 
 

1.0×0.5 
(0402) 
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Table 3.2 Bill of Materials (Part 2) 

 
  

Item Part 
Qu
anti
ty 

Value Part name Manufactu
rer Description Package 

Name 

Standard 
Dimensions 
mm (inch) 

17 
R1, R3, 

R14, R15 
4 1 kΩ   100 mW, ±1 %  1.0×0.5 

(0402) 

18 
R2, R10, 
R12, R16 

4 0 Ω   1 A  1.0×0.5 
(0402) 

19 R4, R17 2 10 kΩ   100 mW, ±1 %  
1.0×0.5 
(0402) 

20 R5 1 160 kΩ   100 mW, ±1 %  
1.0×0.5 
(0402) 

21 R6 1 82 kΩ   100 mW, ±1 %  
1.0×0.5 
(0402) 

22 R7 1 5.1 kΩ   100 mW, ±1 %  
1.0×0.5 
(0402) 

23 R8 1 3.3 kΩ   100 mW, ±1 %  
1.0×0.5 
(0402) 

24 R9 1 100 kΩ   100 mW, ±1 %  
1.0×0.5 
(0402) 

25 R11 1 3.9 kΩ   100 mW, ±1 %  
1.0×0.5 
(0402) 

26 R13 1 2.7 kΩ   100 mW, ±1 %  
1.0×0.5 
(0402) 

27 CN2 1 - 110990030 Seeed Studio 
Grove connector 
4-pin/straight 

 10×5.1×8.1 
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3.3. Board Pattern Drawing 
This board consists of both top and bottom side pattern. The part mounting side is shown as the 

top side and the ultrasonic sensor and connector are mounted on the bottom side. 
<Top Side (Parts Mounting Side)> 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

Fig.3.2 Board Pattern 

 

 

 

 

 

 

 

 

 

 

 

 

Fig.3.3 Substrate Silk 
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Fig.3.4 Substrate Solder 

 
<Bottom Side> 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig.3.5 Board Pattern 

 
  



 
RD162-RGUIDE-01 

2020-03-10 
Rev.11 

11 / 18 © 2020 
Toshiba Electronic Devices & Storage Corporation 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Fig.3.6 Substrate Silk 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig.3.7 Substrate Solder 

 
  



 
RD162-RGUIDE-01 

2020-03-10 
Rev.11 

12 / 18 © 2020 
Toshiba Electronic Devices & Storage Corporation 

4. Operation Procedure 
4.1.  About Arduino and Processing 

Arduino is a palm-sized one-board microcontroller. The microcontroller is selected as the control 
microcontroller for this reference design because it is generally available on the market and can be 
easily got, and if the program is transferred once, the sensor can be operated without a PC. Use the 
Processing to display the measurement results on the PC-screen. 

This reference design provides Arduino operating program and a Processing program that displays 
the status of measurements. To run this program, you must install Arduino IDE and Processing 3 on 
your PCs. Both software are available free of charge on their official sites. Download the software 
and install it on your PC in advance. These software are also needed to edit each program. These 
programs are called "sketches" in Arduino, Processing. 

Moreover, in the case of Windows10, a display window for result of Processing may not start. In 
such a case, it is necessary to change the configuration file of initial value that generated 
automatically at the first time start-up of Processing. Since a solution change with PCs, please 
implement a suitable solution with reference to Web etc. 

Refer to the Commercial Instructions for more information on Arduino and Processing. 
 

4.2.  Connection to Arduino 
 Fig.4.1 shows the connections to the Arduino. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 4.1 Connections to Arduino 

Arduino is used with ”seeed studio Base Shield”. The connection port of the base shield to the 
sensor is connected A3 terminal. Connect the base shield and the PC with a USB cable. 
 

To PC 
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4.3.  Start and Stop 
When the compressed file "RD162-SKETCH-01_E.zip" of the sketch prepared for this sensor is 

downloaded from the following link and decompressed in an appropriate place on the PC, the folder 
containing the two files "US_sensor_Arduino.ino" and "Ultrasonic_sensor.pde" and the usage 
convention is created. Save the file as is. 

 To download sketches → 

Start the Arduino IDE and select “File” → “Open” to open the saved US_sensor_Arduino.ino file. 
The window shown on the left of Fig. 4.2 opens separately from the window opened at startup. 
Select “Sketch” → “Upload” to start compiling the files and write the sketch to the Arduino after 
compiling. When writing is completed successfully, a message appears at the bottom of the window. 
The Arduino is now ready. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 4.2 Arduino IDE Window 

 
  

Click Here 
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Then start the Processing 3. When you start the Processing 3, the window shown in Fig. 4.3 opens. 
Click Get Started at the bottom right of the child window. Then, select File → Open to open the saved 
Ultrasonic_sensor.pde file. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig.4.3 Startup Window of Processing 3 

The window shown in Fig.4.4 opens separately from the window opened at startup. Click the 
operation button (red circle) here to open the result display window and start the measurement. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 4.4 Processing Measurement Start Window 
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Click the stop button (red circle in Fig. 4.5) on this screen to finish the measurement. The Result 
View window closes and the measurement ends. Then close the open windows sequentially. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 4.5 Processing Measurement Completion Window 

You can pause the measurement by clicking on the result display window while the measurement 
is being performed. At this time, the result display window is not closed and the measurement 
waveform remains stopped. To restart the measurement, click on the window again. 
 

4.4.  Precautions for Distance Measurement 
 Depending on the orientation of the ultrasonic sensor, it may receive ultrasonic waves reflected 

off the other object and make it impossible to measure the correct distance. In such a case, 
adjust the position and orientation of the sensor so that the reflected waves other than the 
object are as small as possible. 
 

 The ultrasonic sensors used in this guide are integral sensors that accommodate transmission 
and reception in a single enclosure, but this type inevitably receives reverberation in the 
package and has a lower limit on the distance that can be measured. In this guide, distances 
of about 40 cm or less cannot be measured. If you wish to measure the distance below this, 
use ultrasonic distance sensor that has separate transmitter and receiver. 
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5. Distance Measurement Results 
Fig.5.1 shows the transmission and reception waveforms when measuring a distance of 

approximately 2 m with the ultrasonic distance sensor in this guide. The yellow waveform is the 40-
kHz burst signal output from Arduino, and the green waveform is the sensor output signal input to 
Arduino. 
 
 
 
 
 
 
 
 
 
 
 
 

Fig.5.1 Example Burst Waveform Observed by an Oscilloscope 

In this waveform, the time from the start of transmission until the reception of the reflected wave 
is obtained as 11.5 ms. In this case, the distance is calculated as 1.96 m as shown in Equation 5.1. 
In this example, the speed of sound is assumed to be 340 m/s at room temperature. The time 
measured with this waveform is divided by 2 because it is the time for the ultrasonic wave to and 
from the object to be measured. 

𝐷𝐷＝
𝑣𝑣 × 𝑡𝑡

2
=

340 × 11.5 × 10−3

2
≅ 1.96 (𝑚𝑚)          ・・・・ (5.1)  

D: Distance (m), v: Sound velocity (m/s), t: Propagation time (s) 

 
  

← 40-kHz burst-signal output from Arduino (5 V/div) 

← Sensor-out signals input to Arduino (2 V/div) 

Time axis: 2 ms/div 

Transmit signal wrap 
And reverberation 

11.5 ms 
Receive reflected waves Start transmission 
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Fig.5.2 shows the window for displaying the measurement results of Processing at this time. The 
results window shows the distances processed and calculated by Arduino and matches the values 
found in Equation (5.1). 
 
 
 
 
 
 
 
 
 
 
 

Fig. 5.2 Measuring Result Indication by Processing 

 

  

Upper detection threshold ↓ 
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Terms of Use 
 
This terms of use is made between Toshiba Electronic Devices and Storage Corporation (“We”) and customers who 

use documents and data that are consulted to design electronics applications on which our semiconductor devices 
are mounted (“this Reference Design”). Customers shall comply with this terms of use. Please note that it is assumed 
that customers agree to any and all this terms of use if customers download this Reference Design. We may, at its 
sole and exclusive discretion, change, alter, modify, add, and/or remove any part of this terms of use at any time 
without any prior notice. We may terminate this terms of use at any time and for any reason. Upon termination of 
this terms of use, customers shall destroy this Reference Design. In the event of any breach thereof by customers, 
customers shall destroy this Reference Design, and furnish us a written confirmation to prove such destruction. 
 
1. Restrictions on usage 
1. This Reference Design is provided solely as reference data for designing electronics applications. Customers shall 

not use this Reference Design for any other purpose, including without limitation, verification of reliability. 
2. This Reference Design is for customer's own use and not for sale, lease or other transfer. 
3. Customers shall not use this Reference Design for evaluation in high or low temperature, high humidity, or high 

electromagnetic environments. 
4. This Reference Design shall not be used for or incorporated into any products or systems whose manufacture, 

use, or sale is prohibited under any applicable laws or regulations. 
 
2. Limitations 
1. We reserve the right to make changes to this Reference Design without notice. 
2. This Reference Design should be treated as a reference only. We are not responsible for any incorrect or 

incomplete data and information. 
3. Semiconductor devices can malfunction or fail. When designing electronics applications by referring to this 

Reference Design, customers are responsible for complying with safety standards and for providing adequate designs 
and safeguards for their hardware, software and systems which minimize risk and avoid situations in which a 
malfunction or failure of semiconductor devices could cause loss of human life, bodily injury or damage to property, 
including data loss or corruption. Customers must also refer to and comply with the latest versions of all relevant our 
information, including without limitation, specifications, data sheets and application notes for semiconductor devices, 
as well as the precautions and conditions set forth in the "Semiconductor Reliability Handbook". 
4. When designing electronics applications by referring to this Reference Design, customers must evaluate the whole 

system adequately. Customers are solely responsible for all aspects of their own product design or applications. WE 
ASSUME NO LIABILITY FOR CUSTOMERS' PRODUCT DESIGN OR APPLICATIONS. 
5. No responsibility is assumed by us for any infringement of patents or any other intellectual property rights of 

third parties that may result from the use of this Reference Design. No license to any intellectual property right is 
granted by this terms of use, whether express or implied, by estoppel or otherwise. 
6. THIS REFERENCE DESIGN IS PROVIDED "AS IS". WE (a) ASSUME NO LIABILITY WHATSOEVER, INCLUDING 

WITHOUT LIMITATION, INDIRECT, CONSEQUENTIAL, SPECIAL, OR INCIDENTAL DAMAGES OR LOSS, INCLUDING 
WITHOUT LIMITATION, LOSS OF PROFITS, LOSS OF OPPORTUNITIES, BUSINESS INTERRUPTION AND LOSS OF 
DATA, AND (b) DISCLAIM ANY AND ALL EXPRESS OR IMPLIED WARRANTIES AND CONDITIONS RELATED TO THIS 
REFERENCE DESIGN, INCLUDING WARRANTIES OR CONDITIONS OF MERCHANTABILITY, FITNESS FOR A 
PARTICULAR PURPOSE, ACCURACY OF INFORMATION, OR NONINFRINGEMENT. 
 
3. Export Control 
Customers shall not use or otherwise make available this Reference Design for any military purposes, including 

without limitation, for the design, development, use, stockpiling or manufacturing of nuclear, chemical, or biological 
weapons or missile technology products (mass destruction weapons). This Reference Design may be controlled under 
the applicable export laws and regulations including, without limitation, the Japanese Foreign Exchange and Foreign 
Trade Law and the U.S. Export Administration Regulations. Export and re-export of this Reference Design are strictly 
prohibited except in compliance with all applicable export laws and regulations. 
 
4. Governing Laws 
This terms of use shall be governed and construed by laws of Japan. 
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